BSC-Peg Thunder Token Token Logo

TT [BSC-Peg Thunder] Token

About TT

Listings

Token 18 months
CoinMarketCap 3 years
white paper

ThunderCore is a secure, high-performance, EVM-compatible public blockchain with its own native currency, Thunder Token. The company was founded in 2017 in Silicon Valley by Chris Wang and top researchers and engineers in the field.

With a breakthrough consensus protocol that overcomes the scalability “trilemma” called PaLa, the ThunderCore network offers 4,000+ TPS, sub-second confirmation times, and low gas fees that cost less than a fraction of a dollar ( < $0.00001), giving decentralized applications security and scalability.

Evidently, ThunderCore DApps have been dominating the gaming and gambling category charts week after week, a true testament to how easy it is for DApps to scale on the platform.

ThunderCore also prioritizes interoperability, as native assets on other blockchains (eg. Ethereum, BSC, HECO) can be exchanged amongst each other through a cross-chain mechanism called ThunderCore Bridge.

By solving usability challenges and setting a new standard of reliability and security, ThunderCore leads the effort to bring wide adoption to blockchain technology.

Currently, with an international user base that spans across more than 18 countries, ThunderCore has amassed more than 4 million total addresses and 180 million transactions on its network.

Laser Scorebeta Last Audit: 25 January 2022

report
Token seems to be legit.

Anti-Scam

Links

ZOSLibAddress.isContract(address) (#92-103) is declared view but contains assembly code
UpgradeabilityProxy._implementation() (#153-158) is declared view but contains assembly code
AdminUpgradeabilityProxy._admin() (#291-296) is declared view but contains assembly code
Ensure the attributes of contracts compiled prior to Solidity 0.5.0 are correct.

Additional information: link

UpgradeabilityProxy.constructor(address,bytes)._implementation (#141) shadows:
- UpgradeabilityProxy._implementation() (#153-158) (function)
- Proxy._implementation() (#24) (function)
AdminUpgradeabilityProxy.constructor(address,address,bytes)._implementation (#234) shadows:
- UpgradeabilityProxy._implementation() (#153-158) (function)
- Proxy._implementation() (#24) (function)
AdminUpgradeabilityProxy.constructor(address,address,bytes)._admin (#234) shadows:
- AdminUpgradeabilityProxy._admin() (#291-296) (function)
TokenProxy.constructor(address,address,bytes)._implementation (#325) shadows:
- UpgradeabilityProxy._implementation() (#153-158) (function)
- Proxy._implementation() (#24) (function)
TokenProxy.constructor(address,address,bytes)._admin (#325) shadows:
- AdminUpgradeabilityProxy._admin() (#291-296) (function)
Rename the local variables that shadow another component.

Additional information: link

Modifier AdminUpgradeabilityProxy.ifAdmin() (#217-223) does not always execute _; or revert
All the paths in a modifier must execute _ or revert.

Additional information: link

Proxy._delegate(address) (#32-51) uses assembly
- INLINE ASM (#33-51)
ZOSLibAddress.isContract(address) (#92-103) uses assembly
- INLINE ASM (#101-102)
UpgradeabilityProxy._implementation() (#153-158) uses assembly
- INLINE ASM (#155-158)
UpgradeabilityProxy._setImplementation(address) (#173-181) uses assembly
- INLINE ASM (#178-181)
AdminUpgradeabilityProxy._admin() (#291-296) uses assembly
- INLINE ASM (#293-296)
AdminUpgradeabilityProxy._setAdmin(address) (#302-308) uses assembly
- INLINE ASM (#305-308)
Do not use evm assembly.

Additional information: link

Different versions of Solidity is used:
- Version used: ['0.4.24', '^0.4.24']
- ^0.4.24 (#3)
- ^0.4.24 (#73)
- ^0.4.24 (#109)
- ^0.4.24 (#186)
- 0.4.24 (#321)
Use one Solidity version.

Additional information: link

Proxy._implementation() (#24) is never used and should be removed
Remove unused functions.

Additional information: link

Pragma version^0.4.24 (#3) allows old versions
Pragma version^0.4.24 (#73) allows old versions
Pragma version^0.4.24 (#109) allows old versions
Pragma version^0.4.24 (#186) allows old versions
Pragma version0.4.24 (#321) allows old versions
solc-0.4.24 is not recommended for deployment
Deploy with any of the following Solidity versions: 0.5.16 - 0.5.17, 0.6.11 - 0.6.12, 0.7.5 - 0.7.6 Use a simple pragma version that allows any of these versions. Consider using the latest version of Solidity for testing.

Additional information: link

Low level call in UpgradeabilityProxy.constructor(address,bytes) (#141-147):
- require(bool)(_implementation.delegatecall(_data)) (#145)
Low level call in AdminUpgradeabilityProxy.upgradeToAndCall(address,bytes) (#283-286):
- require(bool)(newImplementation.delegatecall(data)) (#285)
Avoid low-level calls. Check the call success. If the call is meant for a contract, check for code existence

Additional information: link

Holders:
No disclosed threats


Last post in Twitter was more than 30 days ago


Unable to find Youtube account


BscScan page for the token does not contain additional info: website, socials, description, etc.

Additional information: link


Unable to find audit link on the website

No disclosed threats

Price for TT

News for TT